PHP is amongst the most widely used general-purpose server-side coding languages. It’s pretty popular since it is free software, which can be used to build interactive websites like community portals, e-shops or online teaching portals rather than static HTML sites. A PHP module must be installed on the web server where a PHP website is hosted so that its source code can be ‘decoded’. As there aren’t any license taxes for this kind of module and the language itself provides infinite possibilities for the applications that you develop, there’re hundreds of millions of PHP-powered sites. In addition, there are a myriad of PHP scripts, which you can use for your websites without needing to have any programming abilities. Given the fact that there’re a few PHP versions, you need to make sure that the same exact version that you used while developing your website is installed on the web server as well.
PHP 4, PHP 5 and PHP 7 Support in Cloud Hosting
Our cloud hosting servers support different versions of PHP, which means that your sites will work faultlessly no matter if your PHP scripts are outdated. We recognize the fact that an old site does not always imply an insecure one as you may have done plenty of source code modifications. That is why we support PHP 4, PHP 5 and PHP 7 and you can decide which version will be active for your shared web hosting account. You can change the version with a single mouse click within your Hepsia Control Panel and the new settings will take effect momentarily. If you’d like to run both older and newer scripts, there is even an option to use a different PHP version for each of your domains simultaneously.